Welcome, Guest. Please login or register.
December 13, 2019, 12:20:41 PM
Home Home Help Calendar Login Register
News:

Please support BullpupForum.com sponsors!!
. . . Midwest Industries . . . BullpupArmory.com . . . Shooting Sight . . . BullpupUnlimited.com . . . Homeland Guns . . . . . . . . . . . . Desert Tech . . . GallowayPrecision.com . . . K & M Arms . . . . . . Geissele Automatics
+  BULLPUP FORUM
|-+  Bullpup Rifles (Auto & Semi-Auto Centerfire)
| |-+  IWI TAVOR
| | |-+  IWI Tavor SAR & X-95
| | | |-+  300BO Ejection Port Cover Gap?
Pages: [1] Print
Author Topic: 300BO Ejection Port Cover Gap?  (Read 384 times)
MaverickNH
.
Member
**
Offline Offline

Posts: 47


« on: October 19, 2019, 12:54:19 PM »

I have a new Tavor X95 300BO - direct from IWI US with all latest revisions. The Ejection Port Cover, which has 300 Blackout embossed on it, has a 2-3cm long gap less than 1mm wide at the top. I can see light through it.  Is this purpose built in to let gas out?
Logged
cciman
Sr. Member
***
Offline Offline

Posts: 261



« Reply #1 on: October 21, 2019, 11:46:03 PM »

I would opine that it is out of spec, or not aligned on install.  Try reinstalling it, shifting it.  The factory cover is not a great seal.

Gorrilla tape works well too, which is what i used to seal my port.  Or you can buy one of those fancy port covers.  You still will get gases out the top between rail and frame.  I put tape there too.
Logged
Pages: [1] Print 
Jump to:  



Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SimplePortal 2.3.5 © 2008-2012, SimplePortal
Valid XHTML 1.0! Valid CSS!