Welcome, Guest. Please login or register.
September 15, 2019, 10:41:50 AM
Home Home Help Calendar Login Register
News:

+  BULLPUP FORUM
|-+  Bullpup Rifles (Auto & Semi-Auto Centerfire)
| |-+  IWI TAVOR
| | |-+  Tavor7
| | | |-+  Take apart your Piston Assembly before firing
Pages: [1] Print
Author Topic: Take apart your Piston Assembly before firing  (Read 382 times)
OOLF
^
Member
**
Offline Offline

Posts: 28


« on: August 30, 2019, 03:49:26 PM »

Make sure the "Securing Spring" pg. 34, 7.2.1 Removal #2 (sentence on regulator removal) is captive.  Seems mine is missing a roll pin that keeps it from moving/falling out towards the rear of the rifle.  If either movement occurs and it no longer holds the gas regulator in place, the regulator may turn enough to probably go down range while firing.

Saw it last night on second take down (saw the pics from "thehun" and decided to take apart the gas system (pg. 49 "Maintenance page" mentions no disassembly of gas system until after firing 9.2). With the initial cleaning I was going to follow the manual but saw them pics from thehun!  Was going shooting today (first time) so decided last night to take down the gas system (which I should have done anyways) to make sure everything looked like his.

Been a long day getting it shipped and going to log off.  I may post the pics I sent to IWI with more explanation later.  Everything is being taken care of and will update as more is known.

One other thing, when I get it back, I may run a piece of safety/machinist wire through the roll pin if it fits. This would keep it from falling out (if possible) from heating/cooling of the barrel.  Would just be a piece of mind on my part.

Have a safe weekend everyone.

Logged
thehun
Bullpup Fanatic
****
Offline Offline

Posts: 1,583


« Reply #1 on: August 30, 2019, 04:02:58 PM »

Keep us updated.

Mine is fine. But Iíll double check.
« Last Edit: August 30, 2019, 04:05:36 PM by thehun » Logged
thehun
Bullpup Fanatic
****
Offline Offline

Posts: 1,583


« Reply #2 on: August 30, 2019, 04:13:24 PM »

Yup. I have the roll pin in place...

Not sure how that spring stayed in place for you during shipping without that roll pin there.

« Last Edit: August 30, 2019, 05:07:01 PM by thehun » Logged
Dwill
Member
**
Offline Offline

Posts: 43


« Reply #3 on: August 31, 2019, 09:56:30 AM »

Checked mine.  GTG.
Logged
OOLF
^
Member
**
Offline Offline

Posts: 28


« Reply #4 on: August 31, 2019, 04:24:19 PM »

I had taken off the hand guard the night before and didn't feel like taking it off again for the pics to send to IWI, hence the crappy pics.

After noticing the movement when I pushed the spring down toward the butt of the rifle, I took hand guard off and thought that the "1" that is stamped on the side of the regulator base was a set screw.  It actually looked deformed and not as nice as thehuns pics shows.  So thinking it was a set screw, I got one of my terminal screwdrivers and tried to tighten it which is why it looks shiny and more deformed.  I didn't notice a roll pin and didn't even see the hole for it until the armorer at IWI said there was one.  I thought when I first took hand guard off "what a crappy design, all that's holding in the spring is a set screw with nothing to keep it retained if set screw loosens".  Well lo and behold there is a retention device.  Grin
There was some resistance on the spring maybe caused by deformation of the stamped "1" area pressing down it slightly (there was some scraping I noticed on the area visible on the spring-never did fully take it out) which may have kept it in place during shipping.  Just a guess but maybe not.

I'm glad you both had no issues and hopefully no one else does either.
I really didn't want to make a thread on this, but figured it may save someone some headache if theirs is missing.

Take care all.



* IMG_2020.JPG (2001.69 KB, 4032x3024 - viewed 54 times.)
Logged
thehun
Bullpup Fanatic
****
Offline Offline

Posts: 1,583


« Reply #5 on: August 31, 2019, 04:52:13 PM »

hmmm not sure how they missed that...but it is better to make a thread on this and inform...thanks
« Last Edit: August 31, 2019, 04:59:28 PM by thehun » Logged
OOLF
^
Member
**
Offline Offline

Posts: 28


« Reply #6 on: September 10, 2019, 09:56:31 AM »

Supposed to be shipping from IWI today.  Was supposed to ship yesterday, but when I saw the address in the UPS email, I had to call and tell them they had the address wrong (second time).
Was then told it wouldn't ship out until today.
Still haven't received new email.

Looking forward to shooting it.  Found a gunstore/range/restaurant/barbershop with an indoor 100 yard range.  Also, have a coworker with property and 100 yard range.

Will update.

Take care everyone.
Logged
Pages: [1] Print 
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SimplePortal 2.3.5 © 2008-2012, SimplePortal
Valid XHTML 1.0! Valid CSS!