Welcome, Guest. Please login or register.
July 20, 2018, 08:53:09 AM
Home Home Help Calendar Login Register
News:

Please support BullpupForum.com sponsors!!
. . . Midwest Industries . . . BullpupArmory.com . . . Shooting Sight . . . BullpupUnlimited.com . . . Homeland Guns . . . . . . . . . . . . AB Arms . . . GallowayPrecision.com . . . K & M Arms . . . . . . Geissele Automatics
+  BULLPUP FORUM
|-+  Bullpup Rifles (Auto & Semi-Auto Centerfire)
| |-+  IWI TAVOR
| | |-+  IWI Tavor SAR & X-95
| | | |-+  X95 3in Hi at 50ft with Omega 300 Suppressor
Pages: [1] Print
Author Topic: X95 3in Hi at 50ft with Omega 300 Suppressor  (Read 180 times)
MaverickNH
.
Member
**
Offline Offline

Posts: 22


« on: July 10, 2018, 12:48:52 PM »

My X95 in 300 AAC shoots 2-1/2 to 3 inches high with a Silencerco Omega 300 suppressor attached via the quick- release mount over the muzzle brake using S&B 200g Subsonic. Does that makes sense? It cycles fine on subsonic gas setting with or without the can on and leaks a bit of gas at the back of the rail and from the ejection port with the can on.
Logged
SteveD
Member
**
Offline Offline

Posts: 139


« Reply #1 on: July 10, 2018, 08:59:44 PM »

I would say if the shift is consistent, than yes. If it's shooting all over the place something is loose or wrong. I remember I changed out my muzzle device once and it shifted my poi 3" right at 50 yards. I imagine the can is shifting the poi but if you just placed a new muzzle device on and shot with the can that could explain it.
Logged
Pages: [1] Print 
Jump to:  



Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
SimplePortal 2.3.5 © 2008-2012, SimplePortal
Valid XHTML 1.0! Valid CSS!