BULLPUP FORUM

Bullpup Rifles (Auto & Semi-Auto Centerfire) => IWI Tavor SAR & X-95 => Topic started by: boatswain on November 01, 2019, 02:51:20 AM



Title: X95 300BLK jamming with Lancer 300BLK mags
Post by: boatswain on November 01, 2019, 02:51:20 AM
Iím running an X95 suppressed with subsonic rounds and bought the Lancer mags to differentiate 300 from my 556 mags.

Iím seeing a lot of jams, looks like a double feed.

The magazine is LANCER MAGAZINE L5AWM AR-15 .300BLK 30RD TRANSLUCENT SMOKE

Anyone else had this issue? My gas regulator is set correctly.


Title: Re: X95 300BLK jamming with Lancer 300BLK mags
Post by: cciman on November 02, 2019, 10:06:50 AM
Does this happen with generic 556 mags? 
Did the fired round fully eject, (ie new round jammed onto the empty case)?

You have alot going on there with many random variables (suppressor, gas adjustment, ammo, mag).






Title: Re: X95 300BLK jamming with Lancer 300BLK mags
Post by: boatswain on November 02, 2019, 11:10:31 AM
Thanks. I do need to try generic mags again. I seem to recall it did happen before suppression but thatís another variable to eliminate.

I did notice this yesterday when it happened:

- rifle goes click instead of bang
- I pull the charging handle and it jams as described
- Manually clear the jam
- Pull charging handle again and notice the bolt is not fully forward, hence more click

I wonder if my bolt just needs a lot more lube, I use CLP which is pretty light and the gun does feel a bit dry?


Title: Re: X95 300BLK jamming with Lancer 300BLK mags
Post by: cciman on November 02, 2019, 01:47:45 PM
Yeah, clean and lube it.   Try generic mags to rule that one out too.  but seems unlikely to me.

When you "pull the charging handle" after the failure, are you racking and letting go, and double feeding a fresh round on top of a previously partially loaded round, or is there already 2 rounds stuck (one fired, one new)?  Are you pulling the charge handle and letting it fly back, or do you keep your hand on it, and help it in?

High on my initial suspicion list:  ammo not having sufficient charge to eject the empty case and/or fully bounce the bolt on the recoil spring and seat the next round. 

What suppressor?
What ammo, and why did you choose it?  Tested other ammo?
How did you tune/test your gas setting?







Title: Re: X95 300BLK jamming with Lancer 300BLK mags
Post by: boatswain on November 04, 2019, 02:33:09 PM
Good questions, thanks.

Suppressor is a SiCo Chimera 300 and I'm using S&B subsonic 200gr ammo.

I seem to recall it occurring before I put the suppressor on, using supersonic ammo. I need to get back to the range and try it without suppressor and subs.

I didn't do anything special with the gas setting apart from just changing it to position 2 for subsonic.

I have a 500 round training class next weekend, going to be painful if this keeps happening.