BULLPUP FORUM

Bullpup Rifles (Auto & Semi-Auto Centerfire) => IWI Tavor & X-95 => Topic started by: Chrismeany on January 09, 2017, 01:24:51 PM



Title: Bolt and charging rod damage
Post by: Chrismeany on January 09, 2017, 01:24:51 PM
I recently picked up a tavor sar and it's an absolute joy to handle and shoot. I've noticed now after about 1000 rounds though, for some reason the part of the bolt that rides the recoil rod is starting to grind down the metal and it's becoming uneven. Slowly charging you can feel the bolt getting caught on spots of the rod (or it seems) and it's definitely not smooth in some spots. Im aware wear is normal but this type definitely doesnt dfeel to be the case. Maybe I'm wrong though. It's been properly lubricated since first taking it out of its box. Has anyone else experienced something like this?


Title: Re: Bolt and charging rod damage
Post by: Gear Head on January 10, 2017, 02:42:44 PM
Pictures would be helpful here. But in reality it sounds like something you need to contact IWI about.


Title: Re: Bolt and charging rod damage
Post by: RabbitSlayer on January 10, 2017, 03:48:55 PM
Have you cleaned it?  Sounds like carbon build up, tavors get pretty dirty inside.

I've shot about 5000 rounds, and there is no wear at all where the charging handle rod hits the bolt.  I have wear in other areas, but no wear at all where the charging rod hits the bolt.

Put some oil on it, take pictures, and report back.
(https://cdn.meme.am/cache/instances/folder575/400x/67594575.jpg)


Title: Re: Bolt and charging rod damage
Post by: downeyg on January 10, 2017, 04:02:33 PM
Sounds like someone tried to remove the barrel without following the proper procedure and damaged the rod.


Title: Re: Bolt and charging rod damage
Post by: GunStarHero on January 11, 2017, 03:53:47 AM
Sounds like someone tried to remove the barrel without following the proper procedure and damaged the rod.
why I strapped a piece of red duct tape to my bbl key as a reminder.


Title: Re: Bolt and charging rod damage
Post by: Grizz on January 11, 2017, 03:54:41 AM
have you cleaned it or just lubed it?